
 

GIMP NOTES UNIT IV 

 

 

D e v e l o p e d  B y - S a r o j  J u n g h a r e  

 

Page 1 

 

 

BCA III YEAR 

 

GIMP NOTES 

 

UNIT-IV 

 

 
 

 

 

 

 

 

 

 



 

GIMP NOTES UNIT IV 

 

 

D e v e l o p e d  B y - S a r o j  J u n g h a r e  

 

Page 2 

1.2. Raster Image Formats 

 

There are two main kinds of 

graphics: raster graphics and 

vector graphics. 

Raster (or bitmap) graphics is to 

represent graphics into small 

rectangular points called pixels. 

Raster graphics is suitable to 

store digital photos. 

In contrast, vector graphics is to represent graphics into 

geometric objects like lines, curves, polygon, etc. These objects can be enlarged without 

any loss of quality and is therefore useful in visual designs. 

Common raster image formats are listed below: 
 

Extension Name Properties 

BMP Windows Bitmap Accepted in most image processing 
programs. 

JPG (or 
JPEG) 

Joint Photographic Expert 
Group 

Saves storage space using lossy compression. 
Most commonly used with digital photos. 

GIF Graphics Interchange 

Format 

Can only store image in 256 colours. 

Renowned for its ability to store animations. 

PNG Portable Network Graphics Provides better lossless compression than 
BMP and GIF. 

TIF (or 

TIFF) 

Tagged Image File Format Store one or multiple images in the same 
file. Have an extensive set of options (which 

are outside the scope of this book). 

RAW, CR2, 

etc… 

Raw image formats. (They 
are referred as RAW 

despite having other file 
extensions.) 

A good digital camera can store files in raw 
image formats, having minimal processing. 

They can be processed later with the highest 
quality. 

 

Raster image formats used by image editing software 

Image processing software can store extra information, such as text and layers, in its own 

file format. If you save the image in these formats, you can open your image later and 

continue processing. 

 

1. Image Processing Basics 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 1 Comparison of vector 
graphics and raster graphics 
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1.3. Basic Properties of Raster Images 

Extension Software 

XCF GIMP 

PSD Adobe PhotoShop 

UFO PhotoImpact (Corel / Ulead) 

PNG Fireworks (Adobe / Marcomedia) 

It is possible to open these files with other programs. However, the image may have 

subtle differences if other programs are used. 

The dimensions of images can be described in its width and height. For example, an 800 

× 600 image means it has a width of 800 pixels, and a height of 600 pixels. 

To convert the number of pixels into physical units, the dots per inch (DPI) can be 

specified for individual images. 

The ratio of the width and the height is called the aspect ratio. For example a 800 × 600 

photo has an aspect ratio of 4 : 3. If the ASPECt RAtio of A photo is chANged in enlArgement or reduction, the 

imAge APPeARS deformed And looks ugly. 

In colour images, such as digital photos, the colour 

of each pixel is stored in three numbers. The most 

common combination is red, green and blue, 

which are the three additive primary colours. 

This is known as the RGB Colour Space. 

In an image editing software, red, green and blue 

are referred as channels of the image. In addition 

to the colour channels, the alpha channel is used 

to store the opacity of the pixels. (Opacity ranges 

from fully transparent to fully opaque.) 
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The colour depth, or bit depth, is the number of data bits used to represent a 

pixel. The colour depth of a digital photo is usually 24 bits, which is having 8 bits 

in each channel. Some image formats, such as BMP and PNG, allow the use an 

additional 8 bits to store the alpha channel. 

Grayscale images, having only one channel, usually have a colour depth of 8 bit. 
Also, 

Black and white images have a colour depth of 1 bit. 

It is very difficult to select a colour in the RGB Colour Space. Therefore, GIMP 

also uses the HSV Colour Space to represent colours. H stands for hue, S stands 

for saturation and V stands for value. 

Hue ranges from 0 to 360 (degrees). 0° stands for red, 120° stands for green and 

240° stands for blue. 

High saturation means that the pixel is coloured, while 

pixels with zero saturation are black, grey or white 

pixels. Finally, high value means that the pixel is bright 

while low value means a dark colour. 

Other common colour spaces includes HSL, CMYK, Lab and YCbCr. 

 
 

What is GIMP? 
 GIMP stands for GNU Image Manipulation Program. 

 It is Open Source. 

 It is Cross Platform. 

 It is Bitmap Graphics Editor, not for Vector editing. 
 

GIMP Interface 

When you start GIMP7, you will see the following: 

 

 A window called “GNU Image 
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Manipulation Program” which 

contains the menu bar. 

 The Toolbox. Put your mouse over a 

tool/icon to see its description. Below 

the tools there are the options for the 

selected tool. 

 The “Layers, Channel, Paths, Undo” 

window. These are the features that 

make GIMP and other image editing 

software more powerful than Paint. 

 

 

GIMP Toolbox 

Here are the icons in the toolbox and their functions: 

Icon Name Shortcut Description 

Brush tools 

 

Bucket Fill Shift + B Fills an area with a colour or pattern. 

 

Blend (Gradient) L Fills an area with a gradient. 
 

 
Pencil N 

Paints hard-edged lines; that is, the pixels are not 

anti-aliased. 
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Paintbrush P 

Paints soft- or fuzzy-edged lines; that is, the pixels 

are anti-aliased and/or feathered. 

 

Eraser Shift + E Erases pixels from a layer. 

 

Airbrush A Paint tool with variable pressure. 

 

Ink K Paints anti-aliased lines with a simulation of a nib. 

 

Clone C Copies pixels from one part of an image to another. 

 

Heal H Heals image irregularities. 
 

 
Perspective Clone (none) 

Clone from an image source after applying 

perspective transformation. 
 

 

Convolve 

(Blur/Sharpen) 
Shift + U Blurs or sharpens an image. 

 

Smudge S Spreads pixels in the direction of a "push". 
 

 
Dodge/Burn Shift + D 

Lightens or darkens an image's shadows, mid tones, 

or highlights. 

Selection tools 

 

Rectangle R Selects square or rectangular regions. 

 

Ellipse E Selects circular or elliptical regions. 

 

Free (Lasso) F Draw free-form selections. 
 

 

Fuzzy (Magic 

Wand) 
U Select continuous regions of colour. 

 

By Colour Shift + O Select all instances of a colour in an image. 

 

Scissors I Create paths to select shapes. 

 

Foreground (none) Select a region containing foreground objects. 

Transform tools 
 

 
Move M Moves layers and selections. 

 

 
Align Q Align or arrange layers and/or other objects. 

 

 
Crop Shift + C Crops or clips the image. 

 

 
Rotate Shift + R Rotates the active layer, selection or path. 

 

 
Scale Shift + T Scales the active layer, selection or path. 
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Shear Shift + S Shifts part of the image to some direction. 

 

 

 
Perspective 

 
Shift + P 

Changes the perspective of the active layer, selection 

or path. 
 

 
Flip Shift + F Flips layers and selections. 

 

 
Cage Transform Shift + G Deform the selection with a cage. 

Other tools 
 

 
Path B Allows selecting and modifying paths. 

 

 

 
Colour Picker 

 
O 

Selects the colour of any image opened on your 

screen. 
 

 
Magnify (Zoom) Z Alters the zoom level of the image. 

 

 
Measure Shift + M Shows distances and angles. 

 

 
Text M Places text into your image. 

 

Image Window 

A screenshot  of  the  image  window i l l us t ra t ing  the  impor tant  

components   
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In GIMP, each image that you have open is displayed in its own separate window. We will begin with a 

brief description of the components that are present by default in an ordinary image window. 

Title Bar: At the top of the image window you will probably see a emphasis bar, showing the name of the 

image and some basic information about it. The emphasis bar is actually provided by the windowing 

system, not by GIMP itself, so its appearance may vary with different operating systems, window 

managers, and/or themes. 

Image Menu: Directly below the emphasis bar appears the Image Menu (unless it has been suppressed). 

This menu gives you access to nearly every operation you can perform on an image. (There are some 

“global” actions that can only be accessed via the Toolbox menu.) You can also get the Image Menu by 

right-clicking inside the image [1] , or by left-clicking on the little “arrow” symbol in the upper left corner, 

if for some reason you find one of these more convenient. More: most menu operations can also be 

activated from the keyboard, using Alt plus an “accelerator” key underlined in the menu emphasis. 

Menu Button: Clicking on this little button gives you the Image Menu, except in a column instead of a row. 

Mnemonics users who don't want the menu bar visible can acces to this menu by pressing the Shift - F10  

key. 

Ruler: In the default layout, rulers are shown above and to the left of the image, indicating coordinates 

within the image. You can control what type of coordinates are shown if you want to. By default, pixels 

are used, but you can change to other units, using the Units setting described below. One of the most 

important uses of rulers is to create guides. If you click on a ruler and drag into the image display, a 

guideline will be created, which you can use to help you position things accurately. Guides can be moved 

by clicking on them and dragging, or deleted by dragging them out of the image display. 

https://docs.gimp.org/2.2/en/gimp-concepts-image-window.html#ftn.id2554512
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Pointer Coordinates: In the lower left corner of the window is a rectangular area used to show the current 

pointer coordinates (that is, the mouse location, if you are using a mouse), whenever the pointer is within 

the image boundaries. The units are the same as for the rulers. 

Units menu: (This feature is new in GIMP 2.2; it does not appear in GIMP 2.0). By default, the units used 

for the rulers and several other purposes are pixels. You can change to inches, cm, or several other 

possibilities using this menu. 

Zoom button: (This feature is new in GIMP 2.2; it does not appear in GIMP 2.0). There are a number of 

ways to zoom the image in or out, but this menu is perhaps the simplest. 

Status Area: The Status Area appears below the image display. Most of the time, by default, it shows which 

part of the image is currently active, and the amount of system memory that the image is consuming. You 

can customize the information that appears here, by changing your Preferences. When you perform time-

consuming operations, the status area changes temporarily to show what operation is being performed, 

and its state of progress. 

Cancel Button: At the lower right corner of the window appears the Cancel button. If you start a complex, 

time-consuming operation (most commonly a plug-in), and then decide, while it is being computed, that 

you didn't really want to do it after all, this button will cancel it immediately. 

Image Display: The most important part of the image window is, of course, the image display or canvas. It 

occupies the central area of the window, surrounded by a yellow dotted line showing the image boundary, 

against a neutral gray background. You can change the zoom level of the image display in a variety of 

ways, including the Zoom setting described below. 

Image Window Resize Toggle: If this button is pressed, the image itself will be resized if the image window is 

resized. 
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SAVING FILES 

The cross-platform image editor can save files in many formats. 
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The native file format in GIMP is XCF, but it is only used for editing images within 

GIMP. When you finish working on your image, you must convert it to a suitable 

standard format for use elsewhere. For example, you can export a file as a JPEG in 

GIMP. 

To save an image in the JPEG format using GIMP: 

1. Select File > Export As. 

 
2. Enter a name for the file in the Name field, then navigate to where you want 

to save the image. 
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Click on Select File Type to open the list of available file types. 

 

Scroll down the list and select JPEG Image. 
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Select Export to open the Export Image as JPEG dialog box. 

 

Set the compression quality. The Quality slider defaults to 90, but you can adjust it 

up or down to reduce or increase compression. 
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Select Advanced Options if you wish to further customize the file then select 

Export to save your image as a JPEG. 

 

You can use the same method to export images in dozens of other formats including 

GIF, PNG, and BMP. 
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Copy and Paste 

Use File → Create → From Clipboard to create a new image from the clipboard; alternatively, you can 

use Edit → Paste as → New Image. Many applications support copying an image to the clipboard that 

can then be pasted into GIMP. Many operating systems support copying screens to the clipboard. Print  

Screen  typically copies the screen to the clipboard, and Alt + Print Screen  copies only the active 

window. Print screen is not universally supported, and just because your operating system can copy an 

image to the clipboard, does not mean that GIMP can use the image from the clipboard. Your best bet is 

to try it and see if it works. 

How to Copy and Paste Pictures / Image 

How to copy and paste pictures / images into layers in GIMP?  

Explanation 

This explains you how to copy and paste an image or pictures into multiple layers in GIMP. 

Steps to Follow: 

- Launch GIMP. 

- Click File -> Open or else press Ctrl+O to open a file, then choose a file and now click Ok button. 

 
- In case you want the entire image to get copied, click Select->All or else simply press Ctrl+A. 

- Suppose you want to select a certain portion of an image, use the "Rectangle Selection Tool or Ellipse 

Selection Tool or Free Selection Tool" of the Selection Tools from the toolbox. 

 
- The Paste Into option pastes the image over the existing image. In this option, the pasted image can be 

moved to view the existing image. However the "Paste" option simply pastes the image and it cannot be 

moved. 

- Another option named Paste as facilitates four more options which allows the user to paste the image in 

various styles like "New Image, New Layer, New Brush, New Pattern". 

- Select any one of the options - for e.g. New Image. This automatically pastes the image in a new 

window and you can view it. 
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- The New Image and New Layer option do not require any additional process. Just click it and the image 

gets pasted. 

- The New Brush and New Pattern demand an extra action i.e. you need to set the brush/pattern name 

and file name then click "Ok" button to see the image. 

 

 


